// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ftp:\/\/[\w-_.\/]+").unwrap();
let string = "ftp://10.5.0.22/go/to/dir
ftp://name? /root
ftp://name/root";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}