package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ftp:\/\/[\w-_.\/]+`)
var str = `ftp://10.5.0.22/go/to/dir
ftp://name? /root
ftp://name/root`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}