$re = '/ftp:\/\/[\w-_.\/]+/m';
$str = 'ftp://10.5.0.22/go/to/dir
ftp://name? /root
ftp://name/root';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);