using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{1}(?:\.\d{1,5})?|\d{2}(?:\.\d{1,4})?|100(?:\.0{1,3})?)$";
string input = @"1
1.11
1.11111
1.11111111111
99
99.1
99.9999
99.99999
100
100.000
100.0000
100.001
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}