import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{1}(?:\\.\\d{1,5})?|\\d{2}(?:\\.\\d{1,4})?|100(?:\\.0{1,3})?)$";
final String string = "1\n"
+ "1.11\n"
+ "1.11111\n"
+ "1.11111111111\n"
+ "99\n"
+ "99.1\n"
+ "99.9999\n"
+ "99.99999\n"
+ "100\n"
+ "100.000\n"
+ "100.0000\n"
+ "100.001\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}