$re = '/^(\d{1}(?:\.\d{1,5})?|\d{2}(?:\.\d{1,4})?|100(?:\.0{1,3})?)$/m';
$str = '1
1.11
1.11111
1.11111111111
99
99.1
99.9999
99.99999
100
100.000
100.0000
100.001
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);