using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\s*[+-]\s*\d+\s*=\s*\d+$";
string input = @"2 2 + 2
2 +2=4
3 - 2=1
2 4-2=6";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}