$re = '/^\d+\s*[+-]\s*\d+\s*=\s*\d+$/m';
$str = '2 2 + 2
2 +2=4
3 - 2=1
2 4-2=6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);