import re
regex = re.compile(r"^\d+\s*[+-]\s*\d+\s*=\s*\d+$", flags=re.MULTILINE)
test_str = ("2 2 + 2\n"
"2 +2=4\n"
"3 - 2=1\n"
"2 4-2=6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")