#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Za-z0-9]{3,4}\W[A-Za-z0-9]{3,4}\W[A-Za-z0-9]{3,4}\b"
Local $sString = "PCB ASSLY (9C1-E10-010)" & @CRLF & _
"PLEASE ARRANGE QUOTATION FOR THE ABOVE ITEAM AT THE EARLIEST" & @CRLF & _
"" & @CRLF & _
"008-150A-003E" & @CRLF & _
"Form BHUVANESWARI COTSPIN INDIA P LTD" & @CRLF & _
"asdfghjklpo" & @CRLF & _
"" & @CRLF & _
"008/150A/003E" & @CRLF & _
"" & @CRLF & _
"008 150A 003E"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")