$re = '/\b[A-Za-z0-9]{3,4}\W[A-Za-z0-9]{3,4}\W[A-Za-z0-9]{3,4}\b/m';
$str = 'PCB ASSLY (9C1-E10-010)
PLEASE ARRANGE QUOTATION FOR THE ABOVE ITEAM AT THE EARLIEST
008-150A-003E
Form BHUVANESWARI COTSPIN INDIA P LTD
asdfghjklpo
008/150A/003E
008 150A 003E';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);