import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Za-z0-9]{3,4}\\W[A-Za-z0-9]{3,4}\\W[A-Za-z0-9]{3,4}\\b";
final String string = "PCB ASSLY (9C1-E10-010)\n"
+ "PLEASE ARRANGE QUOTATION FOR THE ABOVE ITEAM AT THE EARLIEST\n\n"
+ "008-150A-003E\n"
+ "Form BHUVANESWARI COTSPIN INDIA P LTD\n"
+ "asdfghjklpo\n\n"
+ "008/150A/003E\n\n"
+ "008 150A 003E";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}