package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Za-z0-9]{3,4}\W[A-Za-z0-9]{3,4}\W[A-Za-z0-9]{3,4}\b`)
var str = `PCB ASSLY (9C1-E10-010)
PLEASE ARRANGE QUOTATION FOR THE ABOVE ITEAM AT THE EARLIEST
008-150A-003E
Form BHUVANESWARI COTSPIN INDIA P LTD
asdfghjklpo
008/150A/003E
008 150A 003E`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}