#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?:\/\/"
Local $sString = "https://google.de" & @CRLF & _
"http://google.de" & @CRLF & _
"google.de" & @CRLF & _
"HTTP://GOOGLE.DE" & @CRLF & _
"HTTPS://GOOGLE.DE" & @CRLF & _
"http-service.de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")