re = /https?:\/\//i
str = 'https://google.de
http://google.de
google.de
HTTP://GOOGLE.DE
HTTPS://GOOGLE.DE
http-service.de'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end