package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)https?:\/\/`)
var str = `https://google.de
http://google.de
google.de
HTTP://GOOGLE.DE
HTTPS://GOOGLE.DE
http-service.de`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}