$re = '/https?:\/\//i';
$str = 'https://google.de
http://google.de
google.de
HTTP://GOOGLE.DE
HTTPS://GOOGLE.DE
http-service.de';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);