using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|\h+\K\w+(?:[,\/]?\h*\w+)*(?=\h*(?:\||$))";
string input = @"| VEHICLE | Truck | | Bike
| VEHICLE | Car | | Scooter
| VEHICLE | Sedan | Minivan
| VEHICLE | Truck | | Bike
| VEHICLE | Truck | | Bike|
| VEHICLE | Truck | | Bike
| VEHICLE | Car | | Scooter
| VEHICLE | Sedan | Mini Van | car, van, truck c| pack/cars";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}