$re = '/\|\h+\K\w+(?:[,\/]?\h*\w+)*(?=\h*(?:\||$))/m';
$str = '| VEHICLE | Truck | | Bike
| VEHICLE | Car | | Scooter
| VEHICLE | Sedan | Minivan
| VEHICLE | Truck | | Bike
| VEHICLE | Truck | | Bike|
| VEHICLE | Truck | | Bike
| VEHICLE | Car | | Scooter
| VEHICLE | Sedan | Mini Van | car, van, truck c| pack/cars';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);