import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|\\h+\\K\\w+(?:[,\\/]?\\h*\\w+)*(?=\\h*(?:\\||$))";
final String string = "| VEHICLE | Truck | | Bike\n\n"
+ "| VEHICLE | Car | | Scooter\n\n"
+ "| VEHICLE | Sedan | Minivan\n"
+ "| VEHICLE | Truck | | Bike \n"
+ "| VEHICLE | Truck | | Bike|\n\n"
+ "| VEHICLE | Truck | | Bike\n\n"
+ "| VEHICLE | Car | | Scooter\n\n"
+ "| VEHICLE | Sedan | Mini Van | car, van, truck c| pack/cars";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}