re = /\|\h+\K\w+(?:[,\/]?\h*\w+)*(?=\h*(?:\||$))/m
str = '| VEHICLE | Truck | | Bike
| VEHICLE | Car | | Scooter
| VEHICLE | Sedan | Minivan
| VEHICLE | Truck | | Bike
| VEHICLE | Truck | | Bike|
| VEHICLE | Truck | | Bike
| VEHICLE | Car | | Scooter
| VEHICLE | Sedan | Mini Van | car, van, truck c| pack/cars'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end