#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)^(?!app\.)wedtexts\.com"
Local $sString = "http://app.wedtexts.com" & @CRLF & _
"https://wedtexts.com" & @CRLF & _
"http://blog.wedtexts.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")