const regex = /^(?!app\.)wedtexts\.com/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!app\\.)wedtexts\\.com', 's')
const str = `http://app.wedtexts.com
https://wedtexts.com
http://blog.wedtexts.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}