re = /^(?!app\.)wedtexts\.com/
str = 'http://app.wedtexts.com
https://wedtexts.com
http://blog.wedtexts.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end