$re = '/^(?!app\.)wedtexts\.com/s';
$str = 'http://app.wedtexts.com
https://wedtexts.com
http://blog.wedtexts.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);