using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([A-z0-9#!$%&'\*\+\-\/=\?^_`{}\|\~]+\.?)+|""(\\""|[^""])+"")\@[A-z0-9\-]+(\.[A-z0-9\-]+)*\.[A-z]+";
string input = @"thisisnot\allowed@example.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}