package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(([A-z0-9#!$%&'\*\+\-\/=\?^_`{}\|\~]+\.?)+|"(\\"|[^"])+")\@[A-z0-9\-]+(\.[A-z0-9\-]+)*\.[A-z]+`)
var str = `thisisnot\allowed@example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}