const regex = /^(([A-z0-9#!$%&'\*\+\-\/=\?^_`{}\|\~]+\.?)+|"(\\"|[^"])+")\@[A-z0-9\-]+(\.[A-z0-9\-]+)*\.[A-z]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([A-z0-9#!$%&\'\\*\\+\\-\\\/=\\?^_`{}\\|\\~]+\\.?)+|"(\\\\"|[^"])+")\\@[A-z0-9\\-]+(\\.[A-z0-9\\-]+)*\\.[A-z]+', 'g')
const str = `thisisnot\\allowed@example.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}