#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?im)^([a-z0-9\-.]+\.[a-z0-9\-]+:?[0-9]*)?/?(.+)$"
Local $sString = "gitea/gitea:1.13.7" & @CRLF & _
"kiwigrid/k8s-sidecar:0.1.209" & @CRLF & _
"registry1.dso.mil/ironbank/opensource/docker/registry-v2:2.7.1" & @CRLF & _
"registry.opensource.zalan.do/acid/logical-backup:v1.7.0" & @CRLF & _
"docker.io/dpage/pgadmin4:5.5" & @CRLF & _
"registry1.dso.mil/ironbank/opensource/minio/minio:RELEASE.2021-08-31T05-46-54Z" & @CRLF & _
"ghcr.io/stefanprodan/podinfo:6.0.0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")