import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?im)^([a-z0-9\\-.]+\\.[a-z0-9\\-]+:?[0-9]*)?/?(.+)$";
final String string = "gitea/gitea:1.13.7\n"
+ "kiwigrid/k8s-sidecar:0.1.209\n"
+ "registry1.dso.mil/ironbank/opensource/docker/registry-v2:2.7.1\n"
+ "registry.opensource.zalan.do/acid/logical-backup:v1.7.0\n"
+ "docker.io/dpage/pgadmin4:5.5\n"
+ "registry1.dso.mil/ironbank/opensource/minio/minio:RELEASE.2021-08-31T05-46-54Z\n"
+ "ghcr.io/stefanprodan/podinfo:6.0.0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}