using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?im)^([a-z0-9\-.]+\.[a-z0-9\-]+:?[0-9]*)?/?(.+)$";
string input = @"gitea/gitea:1.13.7
kiwigrid/k8s-sidecar:0.1.209
registry1.dso.mil/ironbank/opensource/docker/registry-v2:2.7.1
registry.opensource.zalan.do/acid/logical-backup:v1.7.0
docker.io/dpage/pgadmin4:5.5
registry1.dso.mil/ironbank/opensource/minio/minio:RELEASE.2021-08-31T05-46-54Z
ghcr.io/stefanprodan/podinfo:6.0.0
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}