#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9]|1[0-3]|[Qq])$"
Local $sString = "1" & @CRLF & _
"a" & @CRLF & _
"Q" & @CRLF & _
"q" & @CRLF & _
"0" & @CRLF & _
"12" & @CRLF & _
"14" & @CRLF & _
"13" & @CRLF & _
"6" & @CRLF & _
"20" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")