package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[1-9]|1[0-3]|[Qq])$`)
var str = `1
a
Q
q
0
12
14
13
6
20
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}