$re = '/^(?:[1-9]|1[0-3]|[Qq])$/m';
$str = '1
a
Q
q
0
12
14
13
6
20
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);