import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[1-9]|1[0-3]|[Qq])$";
final String string = "1\n"
+ "a\n"
+ "Q\n"
+ "q\n"
+ "0\n"
+ "12\n"
+ "14\n"
+ "13\n"
+ "6\n"
+ "20\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}