package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https:\/\/)?vk\.me\/join\/[\w\/=]+`)
var str = `https://vk.me/join/VJQ1d4rf4BlKtUh5W9SEhE1
https://vk.me/join/AJQ1d2e8yflA_MqWop6fVHvN
https://vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR
https://vk.me/join/k5IHCXHpCijsNsN9CvYFVbslrpHVIIUyjFo=
vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}