# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:https:\/\/)?vk\.me\/join\/[\w\/=]+"
test_str = ("https://vk.me/join/VJQ1d4rf4BlKtUh5W9SEhE1\n"
"https://vk.me/join/AJQ1d2e8yflA_MqWop6fVHvN\n"
"https://vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR\n"
"https://vk.me/join/k5IHCXHpCijsNsN9CvYFVbslrpHVIIUyjFo=\n"
"vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.