import Foundation
let pattern = #"(?:https:\/\/)?vk\.me\/join\/[\w\/=]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://vk.me/join/VJQ1d4rf4BlKtUh5W9SEhE1
https://vk.me/join/AJQ1d2e8yflA_MqWop6fVHvN
https://vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR
https://vk.me/join/k5IHCXHpCijsNsN9CvYFVbslrpHVIIUyjFo=
vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)