const regex = /(?:https:\/\/)?vk\.me\/join\/[\w\/=]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https:\\\/\\\/)?vk\\.me\\\/join\\\/[\\w\\\/=]+', 'gm')
const str = `https://vk.me/join/VJQ1d4rf4BlKtUh5W9SEhE1
https://vk.me/join/AJQ1d2e8yflA_MqWop6fVHvN
https://vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR
https://vk.me/join/k5IHCXHpCijsNsN9CvYFVbslrpHVIIUyjFo=
vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}