#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+"
Local $sString = "https://vk.me/join/VJQ1d4rf4BlKtUh5W9SEhE1" & @CRLF & _
"https://vk.me/join/AJQ1d2e8yflA_MqWop6fVHvN" & @CRLF & _
"https://vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR" & @CRLF & _
"https://vk.me/join/k5IHCXHpCijsNsN9CvYFVbslrpHVIIUyjFo="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")