$re = '/.+/m';
$str = 'https://vk.me/join/VJQ1d4rf4BlKtUh5W9SEhE1
https://vk.me/join/AJQ1d2e8yflA_MqWop6fVHvN
https://vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR
https://vk.me/join/k5IHCXHpCijsNsN9CvYFVbslrpHVIIUyjFo=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);