using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+";
string input = @"https://vk.me/join/VJQ1d4rf4BlKtUh5W9SEhE1
https://vk.me/join/AJQ1d2e8yflA_MqWop6fVHvN
https://vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR
https://vk.me/join/k5IHCXHpCijsNsN9CvYFVbslrpHVIIUyjFo=";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}