import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+";
final String string = "https://vk.me/join/VJQ1d4rf4BlKtUh5W9SEhE1\n"
+ "https://vk.me/join/AJQ1d2e8yflA_MqWop6fVHvN\n"
+ "https://vk.me/join/AJQ1d4RkpRl/x/yUdEt7zBNR\n"
+ "https://vk.me/join/k5IHCXHpCijsNsN9CvYFVbslrpHVIIUyjFo=";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}