#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "In Düsseldorf haben wir heute [-+]?(\d*\.)?\d*°C, bei [-+]?(\d*\.)?\d*% Luftfeuchtigkeit\."
Local $sString = "In Düsseldorf haben wir heute 12.3°C, bei 87% Luftfeuchtigkeit."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")