const regex = /In Düsseldorf haben wir heute [-+]?(\d*\.)?\d*°C, bei [-+]?(\d*\.)?\d*% Luftfeuchtigkeit\./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('In Düsseldorf haben wir heute [-+]?(\\d*\\.)?\\d*°C, bei [-+]?(\\d*\\.)?\\d*% Luftfeuchtigkeit\\.', 'g')
const str = `In Düsseldorf haben wir heute 12.3°C, bei 87% Luftfeuchtigkeit.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}