import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "In Düsseldorf haben wir heute [-+]?(\\d*\\.)?\\d*°C, bei [-+]?(\\d*\\.)?\\d*% Luftfeuchtigkeit\\.";
final String string = "In Düsseldorf haben wir heute 12.3°C, bei 87% Luftfeuchtigkeit.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}