re = /In Düsseldorf haben wir heute [-+]?(\d*\.)?\d*°C, bei [-+]?(\d*\.)?\d*% Luftfeuchtigkeit\./
str = 'In Düsseldorf haben wir heute 12.3°C, bei 87% Luftfeuchtigkeit.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end