using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<date>[^"":]+):(?P<price>[^"":]+)";
string input = @"[""March:59"", ""April:64"", ""May:62""]
[""Jan:55""]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}