package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<date>[^":]+):(?P<price>[^":]+)`)
var str = `["March:59", "April:64", "May:62"]
["Jan:55"]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}