$re = '/(?P<date>[^":]+):(?P<price>[^":]+)/m';
$str = '["March:59", "April:64", "May:62"]
["Jan:55"]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);